不乱于心,不困于情。
不畏将来,不念过往。如此,安好。

phpMyAdmin 4.0.x—4.6.2 远程代码执行漏洞

phpMyAdmin是一套开源的、基于Web的MySQL数据库管理工具。在其查找并替换字符串功能中,将用户输入的信息拼接进`preg_replace`函数第一个参数中。

在PHP5.4.7以前,`preg_replace`的第一个参数可以利用\0进行截断,并将正则模式修改为e。众所周知,e模式的正则支持执行代码,此时将可构造一个任意代码执行漏洞。

以下版本受到影响:

– 4.0.10.16之前4.0.x版本
– 4.4.15.7之前4.4.x版本
– 4.6.3之前4.6.x版本(实际上由于该版本要求PHP5.5 ,所以无法复现本漏洞)

启动后,访问`http://192.168.28.4:8080`,即可看到phpMyAdmin的登录页面,账户:root,密码:root。

POC如下

运行POC:

python C:\Users\lenovo\Desktop\a.py -u root -p "root" http://192.168.28.4:8080 -c "system('id')"

赞(0)
未经允许不得转载:seo优化_前端开发_渗透技术 » phpMyAdmin 4.0.x—4.6.2 远程代码执行漏洞